info-beamer

Touch Player no Audio

#1

I am in the process of converting all my 18 stations to the touch player package. Whilst this has not been a problem with normal screens, I encountered problems with my first station using video. I won’t get audio. I have tried it now on site with Pi 3B and audio via headphone jack and in my lab using HDMI on a Pi Zero. Using my zeittunnel video package will play audio n both platforms, no issues at all.

#2

Are you running info beamer hosted or stand alone?

If the latter is the case you may need to
export INFOBEAMER_AUDIO_TARGET=hdmi
before running info beamer executable.

#3

That package doesn’t play audio at the moment. See https://github.com/info-beamer/package-touch-player/blob/master/node.lua#L380-L387.

I can add that as an option.

#4

I’ve just added an option for audio (https://github.com/info-beamer/package-touch-player/commit/157db03a1a5f6bd4cc2adbd059d86beb15e5868d). Can you update the package, change the setting on the config page and see if that works?

1 Like
#5

Thanks for your suggestion Walter, I appreciate your help. We are using the hosted application. We are by far not as deep into the subject as you, still I enjoy reading the exchange of information between you and Florian (amazing, how much you guys know!). As we are running a museum mainly with volunteers like me, we just dig into the subject as necessary. So to say, we are no professionals at all, but help as much as we can.
I am so glad I chose InfoBeamer as our software backbone. The support and help I have received is outstanding!

#6

Hi Michael,
Florian is the one who knows everything, since he has written Info Beamer.
I am a user just like you, albeit a software engineer by profession. My company and me we have installed and used Info Beamer in a museum and we are starting now some digital signage service and offers for exhibition.
We can say that, professionally speaking, it’s a lovely and awesome software system, a robust environment and Florian is very expert, nice and helpful. We are very glad to have found Info-Beamer.

Have fun!

#7

As always, I just followed your instructions and: it works as supposed!
Thanks so much!
Is it OK to use touch player package for my production environment? I have already moved to it on 3 of our 9 stations and it is so much nicer. Have a look->Tunnel-InfoBeamer-Neu5-2019|690x517
With this new concept we are no longer destroying the nice graphics on our walls with black home screens.

#8

Your inlined image is fubar’d. Usually it works by just copying the image from somewhere and pasting it while in the edit box. Can you try that?

#9

… back to my desk, I will give it a second try -> paste didn’t work so I just dropped it into the edit box…

1 Like