info-beamer

Raspberry Pi Zero W Performance

#1

I’ve been running info-beamer hosted on Raspberry Pi 3 B+'s for a while now with no performance issues. I want to switch over to using Raspberry Pi Zero W’s (because of the small form factor and price point).

Does info-beamer perform without any degraded performance on this less powerful device?

#2

For everything except maybe the full screen browser, the Pi 0 is good enough. The GPU is equally powerful, so videos work exactly the same. The only problem with the Pi 0 is that it’s really difficult to purchase more than one.

1 Like
#3

You can actually buy batches now direct from the Foundation - not cost saving but they will sell you 20 or 50 off etc (or at least they offered me that!!_

#4

Neat. I think I read somewhere that the Zeros then get more expensive the more you purchase or something? IIRC that was to counteract the fact that the 5€/USD price is basically the cost of the hardware or even below that and was only meant to get the Pi affordable for hobby only projects and not for commercially rolling out hundreds of them.

#5

The pricing I have is probably supposed to be confidential, but at most it was a pound or two over the best online one off pricing - certainly not enough to NOT use a zero where it is sufficient. It wasn’t hard to get pricing,i just emailed the foundation with our requirements.

#6

I’ve just received my Zero W for testing out the performance, to see if we will be able to use Pi Zero W’s in place of Pi 3b+'s that we normally use, for cost savings.

When using the scheduled player I noticed that my CPU Memory was reporting 95% in use when viewing the device stats.

The videos weren’t as smooth as they are when playing on the Pi 3b+ ( which is to be expected ), for example, videos with a smooth animation would be slightly jumpy.

When I created a setup using the HD Image/Video Player package, the videos played smoothly, but that package has fewer options, and doesn’t include entrance/exit animations.

The CPU memory was around 75% usage using the HD Image/Video Player package.

One other issue, which is probably related more to the TV I was using, is that the ‘Info Bar’ on the Sony Bravia TV would appear between each item playing, this is an area at the top of the TV screen that displays information on the source, such as resolution etc, and appears for a few seconds, before automatically disappearing.

Apparently on my model of Bravia, there’s no way to disable this info bar, my concern is that as we don’t know what TV/Displays we might be connecting to, this could happen when the Pi’s are installed, and would obviously be a problem, as it’s very distracting/annoying.

It’s as though the HDMI output on the Pi Zero W doesn’t continually output a signal, or at least the output changes in some way, making the TV display the source information.

#7

Memory being used is a good thing. This means that files are in the file system cache instead of having to be loaded each time. As long as there’s not too little memory for non-cache use, that’s absolutely fine.

More worrying is that videos are jumpy. For the “Scheduled Player” package, be sure to use the “HD video” tile for video playback. Otherwise anything above 720p is expected to be jumpy.

Is that info bar issue with the HD Player or Scheduled Player? This most likely happens when the Pi is too slow to generate an output HDMI signal. An easy way to do that is to play 3 FullHD videos at the same time. The TV then loses the signal, detects it again and then usually shows that kind of info bar.

#8

Ok, I’ve checked the actual asset itself, and there is a bit of jumpiness in the animation, so that isn’t anything to do with the Pi/info-beamer.

But I still get the info bar popping up when using the Scheduled Player, and this also happens when using the HD Player.

#9

Can you try reducing the video mode from 60 to 50 fps?

#10

I will try that and report back

#11

Ok, it’s exactly the same when set to 50hz, I then tried CEA 19 1280X720 50HZ and still get the same results.

What I have noticed, is that when I uncheck ‘Play Audio’ for a video asset that has audio, or select video assets that don’t contain audio, the info banner doesn’t popup.

I can also disable audio output in the device settings and this will obviously prevent the audio playing/info banner popup too.

For our intended use I don’t think we will require audio anyway, so I’m hoping that even on an install where there is a Sony Bravia TV, as long as we don’t have audio it won’t cause the appearance of the info banner.

I’ve added some entrance animations to the pages containing images, and these also work fine on the Pi Zero W.

#12

That’s weird and I can’t think of any obvious reason why that might be the case. Hm…

#13

I think it’s just the silly Sony Bravia info banner, I’ve read reports of it popping up all the time, on some models it’s possible to completely disable it, but unfortunately it seems mine doesn’t have that option :frowning:

#14

Just tested with the Pi 3b+ and it does exactly the same, so it isn’t anything to do with the setup running from a Pi Zero.

It’s clearly just an annoying ‘feature’ that Sony have on their TV’s

#15

As a note, we have used for a year a bunch of raspberryPi Zero (no wifi) in a museum.
They run a custom LUA script that basically just shows an image or video (a couple of minutes lenght) upon receiving a command via UDP, and it’s perfect. It’s really fast to load up the videos etc (they are Full HD).

Moreover, the S.O. is not the one of info-beamer hosted, but a stripped down raspbian, so I guess the hosted one would be even more performant.

As always, it’s a marvellous piece of software.
W