info-beamer

Multiple WiFis pre-configured

Hello

We are currently assembling a setup of seven Info-Beamer screens that we will be using in a roadshow environment. The problem is that the roadshow will be having a different WiFi network in pretty much every location.

I am concerned to have our roadshow people going in to the file system and changing the WiFi settings on the road. I would mucho more prefer to have multiple WiFis pre-configured and Pi then trying to connect to them and stay on the network that it can get access.

Is this possible?

Regards,

  • Ossi

Taken from here: https://info-beamer.com/doc/device-configuration

Completely custom configuration

Instead or in addition to /config/wireless you can also create the file /config/wpa.conf. It allows you to specify a complete wpa_supplicant.conf configuration file. If you have to refer to the /config directory within that file, be sure to use the /sd/config prefix instead as the SD card is mounted in that location.

Custom configurations allow you to configure almost every type of WiFi setup available, but you’ll have to know the exact parameters required. You might want to turn on debugging.

An example configuration for a corporate 802.1x EAP / PEAP / MSCHAPV2 setup might look like this:

network = {
ssid=""
key_mgmt=WPA-EAP
eap=PEAP
identity=""
password=""
phase1=“peaplabel=auto peapver=0”
phase2=“auth=MSCHAPV2”
}
Additionally you can specify multiple network blocks in a single wpa.conf file. Doing that will allow your device to roam between the two networks as it automatically tries all of them until it finds a working connection.

JW,

Can you share sample configuration file for WPA2(AES) multiple networks ?

CG

Here’s an example for two networks:

network={
        ssid="wifi1"
        psk="password1"
}
network={
        ssid="wifi2"
        psk="password2"
}
2 Likes

Hi

How is this exactly supposed to be working? I tried a very simple setup of using my iPhone as access point. It works fine when I have specified in wireless file the simple configuration of
iPhone(Ossi)
PassWord

But when trying following:

  • Delete the file wireless from the directory /config/

  • Create file wpa.conf in the directory of /config/ with content

    network={
    ssid=“iPhone(Ossi)”
    psk=“PassWord”
    }
    network={
    ssid=“TotalPlay”
    psk=“PassWord2”
    }

However, Pi does not connect to neither of these networks. If the folder has only wireless file present, they connect fine.

Googling around the WPA supplicant configuration syntax gives multiple options of file names etc. So just making sure that the syntax and file names are correct. (For example https://www.raspberrypi.org/documentation/configuration/wireless/wireless-cli.md is specifying that the file path should be /etc/wpa_supplicant/wpa_supplicant.conf). Also in the Device configuration screen (Device Screen > Configuration > Network) it says “Additional wpa_supplicant.conf settings”

It is wpa.conf. Maybe the problem is that you’re using Windows-Style line endings for the file? If you have a decent text editor like notepad++, you can switch between Windows/DOS style and unix. info-beamer expects unix style line endings. I don’t have the editor install at the moment, but here’s how you might change those settings.

Can I keep both files, “wireless” and “wpa.conf” ?

CG

Yes. In either or both files exist, WiFi will be enabled. If both exist, their settings will be merged.