info-beamer

Easy-setup 3G Shield for Raspberry


#21

Glad it’s working for you, it’s certainly a very compact solution.

We had the need for a wired ethernet solution, for both reliability and also to enable us to add an external video stream to the local network and then using the local network stream url address to add to the scheduled player setup.

As I mentioned, the MR200 also has the option to use external antennas for better reception.


#22

Great solution! I’ll try it out.


#23

I also think it’s nice but what with running it directly from infobeamer, there is no /config/wireless as well as /dev directories to setup the 3g/lte usb dongle.


#24

What do you mean by “directly from infobeamer”? If there is no existing /config/wireless file, either create it manually or use the download page at https://info-beamer.com/download, select customize and enter your WiFi credentials to get an installation file with them added automatically.

With regards to the /dev directory: The dongle linked just uses usb as its power source. The Pi itself never speaks to it using USB, only through WiFi. So you don’t have to mess with anything in /dev or require any additional software or drivers. It’s basically a WiFi router that uses any USB power source.


#25

I think Walters solution uses the usb dongle that is a lte modem. How can that be configured to provide internet connection?


#26

Hi,
I confirm what @infobeamer-fw writes.

I’ve tried a proper dongle but, as @marcink points out, it’s not easily configurable by a Raspberry, let alone one with Info-Beamer OS.
After ditching this one, I’ve tried both the Teltonika and a Huawei Wingle. Both are just 3G modems that route traffic to wifi (and ethernet, in the Teltonika case).
All you have to do is configure it on a normal PC (or use the default values) and put the SSID and wifi password in the /config/wireless file on the Raspberry.

The Teltonika modem has an external power adapter, while the Huawei Wingle (Huawei E8372h-153 Router ) plugs directly in to a USB port, and as such uses the Raspberry just to draw power.

Please see further up in the thread for more info.
Good luck


#27

so as I supposed, there is no way to configure the infobeamer to use usb modem with lte, just only a some wifi router powered with usb from rpi and transmit the data over wifi not over usb.


#28

That’s correct at the moment. Adding support for various LTE modems, the probably vastly different configurations required depending on provider or country and probably other issues sounds like a huge task. It’s so much easier to rely on a small existing external interface (in this case “using WiFi”) that already works. Especially since the linked Huawei router costs 50$ or so and can potentially be shared among multiple devices.


#29

In fact, since I’m nerd inside, my first thought was to grab one of various shields available to snap on the GPIO raspberry ports…
After a little bit of scouting I discovered that the shields:

  • needed a separate 3G modem to be bought and snapped in
  • needed to be obscurely configured
  • the connection needed then to be se tup with good old AT-XX modem commands via serial port, like in the good old 80s and 90s
  • the overall bare metal cost was around or more the 50 euros of a Wingle…

So what for? I completely subscribe to @infobeamer-fw view. At the moment, unless in the future the Raspberry will integrate natively a 3G SIM or eSIM, I see this as the most robust, aesthetically clean and compact solution.


#30

could be you’re right @walter and @infobeamer-fw, since sometimes it’s not worth of finding wheel from beginning. But i would rather insist that the support for usb device and AT commands it’s not so tough to configure, if it is available. Immagine having 100 of displays each with need of lte/3g. Configuring, even same wifi routers is a mess, having instead a 100 usb modems differs only changing pin code for the sim card.
Even such simple thing as hung wifi router gives a problem, and having a hung usb modem is enough to reboot whole set to regain the connectivity. No risk of configuration reset, and of course no ‘home’ hackers trying to access your wifi to drain the internet.
there are always pro/con’s but I think it’s worth of re-thinking.


#31

I see your point. Do you have a suggestions for an LTE modem that is available world-wide, has stable drivers and won’t disappear from the shelves in 6 months? I want features to work reliably and the best way to do that is to only support a single type of hardware and ensure that it works. Similar to how WiFi worked before the Pi got that out of the box.

Since I have absolutely no experience with GSM modems, how does that generally work? They appear as serial(?) devices and you use pppd/wvdial to run a provider specific script with AT commands to you get a connected and configured network device? The various tutorials I’ve seen so far hugely vary in how that works, with some requiring to run mode-switch to get the modem into the right mode of operation and then requiring a reboot (yuk!). Others seem to work as usb network device and bring their own web server for configuration on some internal IP. That all looks rather messy.


#32

I think that the huaweii e173 was one of the most popular models of usb modems.
You’re right that creating one good solution for all the devices is not so much reliable as the one solution for wifi standard. I won’t inssist much and ask network provider to provide the wifi routers.
The only gain would be the the support for usb devices and modem commands that could be use of for users that use 3g/lte modems hut’s.
the GSM modems work great as a ttyUSB devices with wvdial and some config with at commands.
After rethinking I must admit that I’m convinced to use the wifi router instead of a usb modem.

Frankly saying one more thing that regards older RPI’s than 3 series. It would be nice to have some info how to configure the usb wifi dongle to use the wifi :slight_smile:


#33

Actually that’s pretty simple: Just create /config/wireless and info-beamer will use the WiFi dongle. See https://info-beamer.com/doc/device-configuration#wificonfiguration


#34

Why after the reboot the config dir and it’s content dissapears?


#35

I would guess you chose the wrong partition while editing the /config directory. info-beamer hosted uses A/B booting and Windows unfortunately shows both partitions even though one is marked as containing a Linux filesystem. You must only edit/create config files on the first one. Unfortunately Windows makes it rather difficult to find out which one is which :-\

If you place a configuration on the wrong one, it’s completely overwritten if you do the next system upgrade/config change. This still doesn’t explain having no /config directory. That can only happen if it was omitted while copying over the file initially.


#36

Ok, I’ll configured all that was needed, just to be sure will the TP-Link TL-WN725N 2.0 work with the beamer? https://wikidevi.com/wiki/TP-LINK_TL-WN725N_v2
The chipset is not CUS but EUS - is that a significant difference?


#37

No idea, sorry. Haven’t tried that one. Are you working with an older Pi that doesn’t have WiFi built-in?


#38

yes in this case yes - I’ve one older for performance tests. If something works on pi 2 should also on pi 3. Well then I need to test it with pi3.