info-beamer

Do not wait for Network


#1

I noticed that setups would not load when there is no connectivity, Is it possible to have a DO NOT WAIT FOR NETWORK patch to start displaying playlists without network?


#2

There are two different factors at play here:

  1. The info-beamer OS has to install the configured setup again after booting up.
  2. The configured setup has to run without a proper time

You can see which one affects you by looking at the screen: If you still see the info-beamer boot screen, it’s 1. If the boot screen disappeared and you see a black screen or other messages, it’s 2.

1: There is a race condition in the current stable release that sometimes causes the setup to not install even if all files required are locally cached. This is fixed in the next release. If you want, you can test this by installing the testing release of the OS.

2: Some setups by their design need a correct time: Most video walls are synchronized by the wall clock, so without proper time, it’s impossible to do that. They might be changed to work regardless by somehow making the devices talk to each other, but that’s a whole bundle of additional complexity and source of problems. For example: Some WiFi networks don’t allow devices to communicate with each other (“client isolation”) at all. The Scheduled Player was recently fixed, so playlists that are always schedule also play if there is no correct time set yet.

Which Package are you using for your setups?


#3

Thanks for the prompt response.

For the time being I am using the HDimage/ Video player package.
In fact all the devices have correctly taken all the necessary configs and setups. ( By the way I can assert the efficiency of the Peer 2 Peer connection)… They play fine even when I turn off the connection (for test purposes). The problem arises when the devices are shut down and booted back on, without connection. They stop at the black Loading… page.

How can I bypass that and get to the cache directly, without the device having to detect a connection?


#4

You have the [X] synced playback option enabled in your setup. This forces the setup to wait for a correct time, as all devices at set to play videos at the same time. Without a proper time, it’s impossible to do that. So they have to wait before they start. If you disable this setting, they should play without a stable internet connection while starting.


#5

I thought so too, but forgot the sync button… I’ll try that and get back here.


#6

Solved… THANK YOUUUU :smiley: