info-beamer

Allow audio to be output from videos in Scheduled Player


#1

I need to have audio output from the Pi when playing videos in the Scheduled player.

Ideally I could select which asset would have audio output in the settings.


#2

I’d like to thank Florian for his amazing support on this.

The option to allow audio output was enabled on the Pi, and a check box to play audio for video files was added within the hour of my request!

My Pi now outputs audio via it’s HDMI port when playing video files in the scheduled player.

What awesome support :slight_smile:


#3

Glad to help. That reminded me to update the official package the the solutions page, so its official page now also shows this feature: https://info-beamer.com/pkg/4765 (see beta14 in the changelog section).


#4

oddly enough I’m now not getting any audio from my setup. not sure if this is due to using either the Stable or Testing channel on my device?


#5

Ensure that you actually enabled audio video HDMI. See https://info-beamer.com/doc/device-configuration#specifyaudiotarget


#6

Ah!

I believe last time I set this up you assisted me with those changes, so I didn’t realise I had to make those changes, I’ll give it a go!


#7

In the config folder I’ve created a .txt file named audio.txt, with the word ‘hdmi’ in it.

I’m not sure that this is correct? it hasn’t made a difference anyway!


#8

Remove the file extension. The expected filename is /config/audio, not /config/audio.txt.


#9

I just realised that’s what I did wrong, thank you though :slight_smile: